|
Światło dzienne ujrzały 4 dokumenty RFC, których zadaniem jest przedstawić obecny stan wiedzy na temat technicznych aspektów IRC-a.
Dokumenty RFC oznaczone numerami 2810-2813 mają charakter informacyjny i od strony technicznej opisują poszczególne zagadnienia związane z protokołem IRC. Tworzą one rozwinięcie i jednocześnie wersję bardziej "na czasie" dokumentu RFC 1459, który przez lata stanowił podstawę dla twórców oprogramowania serwerów i klientów IRC. Nowe RFC są autorstwa C. Kalta (prawdopodobnie operatora serwera IRCnetu irc.stealth.net) i ukazały się 24 (RFC 2810) i 27 (RFC 2811-2813) kwietnia br.
RFC 2810 (Internet Relay Chat: Architecture) wprowadza pojęcie IRC oraz pojęcia związane z jego funkcjonowaniem (takie jak klient, serwer, sieć, kanał), określa wzajemne między nimi zależności i wskazuje na związane z tym - jeszcze nie rozwiązane - problemy.
RFC 2811 (Internet Relay Chat: Channel Management) to kompendium wiedzy na temat rodzajów kanałów, ich atrybutów, powiązań z innymi aspektami IRC, znanych problemów związanych z ich funkcjonowaniem oraz obecnej implementacji (tj. zastosowania w praktyce) idei kanału.
RFC 2812 (Internet Relay Chat: Client Protocol) to informacje na temat sposobów komunikacji na drodze klient-serwer (patrząc od strony klienta, tj. dostępne dla klienta polecenia i ich składnia, możliwe odpowiedzi serwera), ich implementację i związane z nimi problemy.
RFC 2813 (Internet Relay Chat: Server Protocol) opisuje protokół, który umożliwia serwerowi porozumiewać się z innymi serwerami w obrębie tej samej sieci, jego implementację i problemy wiążące się z jego użytkowaniem.
Jako jedyna obecna implementacja idei opisywanej w RFC 2810-2813 podawany jest "IRC server" w wersji 2.10 (stosowany w sieci IRCnet).
Jako najbardziej palące problemy Kalt opisuje ograniczenia rozrostu sieci (spowodowane m.in. tym, że każdy serwer w sieci musi wiedzieć zarówno o każdym innym serwerze, jak i każdym użytkowniku w tej sieci) oraz drzewiastą strukturę sieci (bez łączeń cyklicznych, które mogłyby rozwiązać problem splitów). [mdb]
> RFC 1459: Internet Relay Chat Protocol - www.olimp.kki.pl/plikownia/rfc1459.txt
> RFC 2810: Internet Relay Chat: Architecture - www.olimp.kki.pl/plikownia/rfc2810.txt
> RFC 2811: Internet Relay Chat: Channel Management - www.olimp.kki.pl/plikownia/rfc2811.txt
> RFC 2812: Internet Relay Chat: Client Protocol - www.olimp.kki.pl/plikownia/rfc2812.txt
> RFC 2813: Internet Relay Chat: Server Protocol - www.olimp.kki.pl/plikownia/rfc2813.txtPrzedruk dozwolony z podaniem źródła: Olimp IRCnews - www.olimp.kki.pl